#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^\w+(?=\.))"
Local $sString = "all_scores.feather" & @CRLF & _
"scores_01_clean.feather" & @CRLF & _
"scores_02_clean.xlsx" & @CRLF & _
"analysis_descriptive.nb.html" & @CRLF & _
"analysis_table_01.docx" & @CRLF & _
"python_model.py"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")