use strict;
my $str = 'all_scores.feather
scores_01_clean.feather
scores_02_clean.xlsx
analysis_descriptive.nb.html
analysis_table_01.docx
python_model.py';
my $regex = qr/(^\w+(?=\.))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}