using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\w+(?=\.))";
string input = @"all_scores.feather
scores_01_clean.feather
scores_02_clean.xlsx
analysis_descriptive.nb.html
analysis_table_01.docx
python_model.py";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}