$re = '/(^\w+(?=\.))/m';
$str = 'all_scores.feather
scores_01_clean.feather
scores_02_clean.xlsx
analysis_descriptive.nb.html
analysis_table_01.docx
python_model.py';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);