#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![^.\n]*\.[^.\n]*\.)[A-Za-z](?:\.?[A-Za-z0-9]){7,14}$"
Local $sString = "a123456" & @CRLF & _
"abcdefgh" & @CRLF & _
"abcdefghij12345" & @CRLF & _
"abcdefghij123456" & @CRLF & _
"abcdefghi.j12345" & @CRLF & _
"abcdefghi.j.123" & @CRLF & _
"abcdefghij1234567"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")