const regex = /^(?![^.\n]*\.[^.\n]*\.)[A-Za-z](?:\.?[A-Za-z0-9]){7,14}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?![^.\\n]*\\.[^.\\n]*\\.)[A-Za-z](?:\\.?[A-Za-z0-9]){7,14}$', 'gm')
const str = `a123456
abcdefgh
abcdefghij12345
abcdefghij123456
abcdefghi.j12345
abcdefghi.j.123
abcdefghij1234567`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}