import re
regex = re.compile(r"^(?![^.\n]*\.[^.\n]*\.)[A-Za-z](?:\.?[A-Za-z0-9]){7,14}$", flags=re.MULTILINE)
test_str = ("a123456\n"
"abcdefgh\n"
"abcdefghij12345\n"
"abcdefghij123456\n"
"abcdefghi.j12345\n"
"abcdefghi.j.123\n"
"abcdefghij1234567")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")