using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?![^.\n]*\.[^.\n]*\.)[A-Za-z](?:\.?[A-Za-z0-9]){7,14}$";
string input = @"a123456
abcdefgh
abcdefghij12345
abcdefghij123456
abcdefghi.j12345
abcdefghi.j.123
abcdefghij1234567";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}