$re = '/^(?![^.\n]*\.[^.\n]*\.)[A-Za-z](?:\.?[A-Za-z0-9]){7,14}$/m';
$str = 'a123456
abcdefgh
abcdefghij12345
abcdefghij123456
abcdefghi.j12345
abcdefghi.j.123
abcdefghij1234567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);