#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)data\.(?:test\w*|new)?(?:ID)?=([^,]+)"
Local $sString = "data.testID=abd.123," & @CRLF & _
"" & @CRLF & _
"data.newID=abc.123.123," & @CRLF & _
"" & @CRLF & _
"data.testcaseID=abc.1_2," & @CRLF & _
"" & @CRLF & _
"data.testid=abc.123," & @CRLF & _
"" & @CRLF & _
"data.TestCaseID=abc.1.2,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")