re = /data\.(?:test\w*|new)?(?:ID)?=([^,]+)/mi
str = 'data.testID=abd.123,
data.newID=abc.123.123,
data.testcaseID=abc.1_2,
data.testid=abc.123,
data.TestCaseID=abc.1.2,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end