package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)data\.(?:test\w*|new)?(?:ID)?=([^,]+)`)
var str = `data.testID=abd.123,
data.newID=abc.123.123,
data.testcaseID=abc.1_2,
data.testid=abc.123,
data.TestCaseID=abc.1.2,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}