using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"data\.(?:test\w*|new)?(?:ID)?=([^,]+)";
string input = @"data.testID=abd.123,
data.newID=abc.123.123,
data.testcaseID=abc.1_2,
data.testid=abc.123,
data.TestCaseID=abc.1.2,";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}