import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "data\\.(?:test\\w*|new)?(?:ID)?=([^,]+)";
final String string = "data.testID=abd.123,\n\n"
+ "data.newID=abc.123.123,\n\n"
+ "data.testcaseID=abc.1_2,\n\n"
+ "data.testid=abc.123,\n\n"
+ "data.TestCaseID=abc.1.2,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}