using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-3]?\d([\,\-\/ ])(?<Bulan>(?<Januari>[Jj]an|[Jj]anuari)|(?<Februari>[Ff]ebruari|[Ff]eb)|(?<Maret>[Mm]aret|[Mm]ar)|(?<April>[Aa]pril|[Aa]pr)|(?<Mei>[Mm]ei|[Mm]ay)|(?<Juni>[Jj]uni|[Jj]une)|(?<Juli>[Jj]uli|[Jj]uly)|(?<Agustus>[Aa]gustus|[Aa]ug)|(?<September>[Ss]eptember|[Ss]ept)|(?<Oktober>[Oo]ktober|[Oo]ct)|(?<November>[Nn]ovember|[Nn]ov)|(?<Desember>[Dd]esember|[Dd]ec))\1([12]\d{3}|\d{2})";
string input = @"12-Maret-2021";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}