$re = '/[0-3]?\d([\,\-\/ ])(?<Bulan>(?<Januari>[Jj]an|[Jj]anuari)|(?<Februari>[Ff]ebruari|[Ff]eb)|(?<Maret>[Mm]aret|[Mm]ar)|(?<April>[Aa]pril|[Aa]pr)|(?<Mei>[Mm]ei|[Mm]ay)|(?<Juni>[Jj]uni|[Jj]une)|(?<Juli>[Jj]uli|[Jj]uly)|(?<Agustus>[Aa]gustus|[Aa]ug)|(?<September>[Ss]eptember|[Ss]ept)|(?<Oktober>[Oo]ktober|[Oo]ct)|(?<November>[Nn]ovember|[Nn]ov)|(?<Desember>[Dd]esember|[Dd]ec))\1([12]\d{3}|\d{2})/m';
$str = '12-Maret-2021';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);