import re
regex = re.compile(r"[0-3]?\d([\,\-\/ ])(?<Bulan>(?<Januari>[Jj]an|[Jj]anuari)|(?<Februari>[Ff]ebruari|[Ff]eb)|(?<Maret>[Mm]aret|[Mm]ar)|(?<April>[Aa]pril|[Aa]pr)|(?<Mei>[Mm]ei|[Mm]ay)|(?<Juni>[Jj]uni|[Jj]une)|(?<Juli>[Jj]uli|[Jj]uly)|(?<Agustus>[Aa]gustus|[Aa]ug)|(?<September>[Ss]eptember|[Ss]ept)|(?<Oktober>[Oo]ktober|[Oo]ct)|(?<November>[Nn]ovember|[Nn]ov)|(?<Desember>[Dd]esember|[Dd]ec))\1([12]\d{3}|\d{2})", flags=re.MULTILINE)
test_str = "12-Maret-2021"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")