use strict;
my $str = '12-Maret-2021';
my $regex = qr/[0-3]?\d([\,\-\/ ])(?<Bulan>(?<Januari>[Jj]an|[Jj]anuari)|(?<Februari>[Ff]ebruari|[Ff]eb)|(?<Maret>[Mm]aret|[Mm]ar)|(?<April>[Aa]pril|[Aa]pr)|(?<Mei>[Mm]ei|[Mm]ay)|(?<Juni>[Jj]uni|[Jj]une)|(?<Juli>[Jj]uli|[Jj]uly)|(?<Agustus>[Aa]gustus|[Aa]ug)|(?<September>[Ss]eptember|[Ss]ept)|(?<Oktober>[Oo]ktober|[Oo]ct)|(?<November>[Nn]ovember|[Nn]ov)|(?<Desember>[Dd]esember|[Dd]ec))\1([12]\d{3}|\d{2})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}