#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^posix(\d*)$|^((\d\d).(\d\d)(.(\d\d\d\d))?)?T((\d\d)(:(\d\d))?)?$"
Local $sString = "T" & @CRLF & _
"" & @CRLF & _
"T15" & @CRLF & _
"T15:03" & @CRLF & _
"" & @CRLF & _
"16.02T" & @CRLF & _
"16.02.2000T" & @CRLF & _
"" & @CRLF & _
"16.02T15" & @CRLF & _
"16.02T15:03" & @CRLF & _
"16.02.2000T15" & @CRLF & _
"16.02.2000T15:03" & @CRLF & _
"" & @CRLF & _
"posix2" & @CRLF & _
"posix9876543210"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")