import Foundation
let pattern = #"^posix(\d*)$|^((\d\d).(\d\d)(.(\d\d\d\d))?)?T((\d\d)(:(\d\d))?)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
T
T15
T15:03
16.02T
16.02.2000T
16.02T15
16.02T15:03
16.02.2000T15
16.02.2000T15:03
posix2
posix9876543210
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)