$re = '/^posix(\d*)$|^((\d\d).(\d\d)(.(\d\d\d\d))?)?T((\d\d)(:(\d\d))?)?$/m';
$str = 'T
T15
T15:03
16.02T
16.02.2000T
16.02T15
16.02T15:03
16.02.2000T15
16.02.2000T15:03
posix2
posix9876543210';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);