# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^posix(\d*)$|^((\d\d).(\d\d)(.(\d\d\d\d))?)?T((\d\d)(:(\d\d))?)?$"
test_str = ("T\n\n"
"T15\n"
"T15:03\n\n"
"16.02T\n"
"16.02.2000T\n\n"
"16.02T15\n"
"16.02T15:03\n"
"16.02.2000T15\n"
"16.02.2000T15:03\n\n"
"posix2\n"
"posix9876543210")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.