using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^posix(\d*)$|^((\d\d).(\d\d)(.(\d\d\d\d))?)?T((\d\d)(:(\d\d))?)?$";
string input = @"T
T15
T15:03
16.02T
16.02.2000T
16.02T15
16.02T15:03
16.02.2000T15
16.02.2000T15:03
posix2
posix9876543210";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}