#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.+?)(?:\sAA BB\s*.*?)"
Local $sString = "01 02 03 AA BB CC FF 01 02 03 01 02 03 01 02 AF AA BB CC FF 01 02 03 01 02 AA BB 01 02 AF AA BB CC FF 01 02 03 01 02 AA BB 01 02 AF AA BB CC FF "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")