// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.+?)(?:\sAA BB\s*.*?)").unwrap();
let string = "01 02 03 AA BB CC FF 01 02 03 01 02 03 01 02 AF AA BB CC FF 01 02 03 01 02 AA BB 01 02 AF AA BB CC FF 01 02 03 01 02 AA BB 01 02 AF AA BB CC FF ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}