using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+?)(?:\sAA BB\s*.*?)";
string input = @"01 02 03 AA BB CC FF 01 02 03 01 02 03 01 02 AF AA BB CC FF 01 02 03 01 02 AA BB 01 02 AF AA BB CC FF 01 02 03 01 02 AA BB 01 02 AF AA BB CC FF ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}