package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.+?)(?:\sAA BB\s*.*?)`)
var str = `01 02 03 AA BB CC FF 01 02 03 01 02 03 01 02 AF AA BB CC FF 01 02 03 01 02 AA BB 01 02 AF AA BB CC FF 01 02 03 01 02 AA BB 01 02 AF AA BB CC FF `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}