import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.+?)(?:\\sAA BB\\s*.*?)";
final String string = "01 02 03 AA BB CC FF 01 02 03 01 02 03 01 02 AF AA BB CC FF 01 02 03 01 02 AA BB 01 02 AF AA BB CC FF 01 02 03 01 02 AA BB 01 02 AF AA BB CC FF ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}