# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/0+(\d+)/$1/gm;t' <<< "004frac{0030900000}{001}"