$re = '/0+(\d+)/m';
$str = '004frac{0030900000}{001}';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;