const regex = /0+(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('0+(\\d+)', 'gm')
const str = `004frac{0030900000}{001}`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);