using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"0+(\d+)";
string substitution = @"$1";
string input = @"004frac{0030900000}{001}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}