package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)0+(\d+)`)
var str = `004frac{0030900000}{001}`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}