#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\b|_)foo(?:\b|_)"
Local $sString = "foo ---foo-- abc.foo.def 123(foo)456" & @CRLF & _
"_foo_ (_foo_)" & @CRLF & _
"" & @CRLF & _
"foofooo foo_foo" & @CRLF & _
"___foo___" & @CRLF & _
"" & @CRLF & _
"xxx_foo_zzzz xxxfoozzz" & @CRLF & _
"0000 foo_" & @CRLF & _
"9999 _foo..." & @CRLF & _
"" & @CRLF & _
"foo_abc cba_foo" & @CRLF & _
"" & @CRLF & _
"a foo_ _foo bar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")