// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:\b|_)foo(?:\b|_)").unwrap();
let string = "foo ---foo-- abc.foo.def 123(foo)456
_foo_ (_foo_)
foofooo foo_foo
___foo___
xxx_foo_zzzz xxxfoozzz
0000 foo_
9999 _foo...
foo_abc cba_foo
a foo_ _foo bar";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}