import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\b|_)foo(?:\\b|_)";
final String string = "foo ---foo-- abc.foo.def 123(foo)456\n"
+ "_foo_ (_foo_)\n\n"
+ "foofooo foo_foo\n"
+ "___foo___\n\n"
+ "xxx_foo_zzzz xxxfoozzz\n"
+ "0000 foo_\n"
+ "9999 _foo...\n\n"
+ "foo_abc cba_foo\n\n"
+ "a foo_ _foo bar";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}