import re
regex = re.compile(r"(?:\b|_)foo(?:\b|_)")
test_str = ("foo ---foo-- abc.foo.def 123(foo)456\n"
"_foo_ (_foo_)\n\n"
"foofooo foo_foo\n"
"___foo___\n\n"
"xxx_foo_zzzz xxxfoozzz\n"
"0000 foo_\n"
"9999 _foo...\n\n"
"foo_abc cba_foo\n\n"
"a foo_ _foo bar")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")