$re = '/(?:\b|_)foo(?:\b|_)/';
$str = 'foo ---foo-- abc.foo.def 123(foo)456
_foo_ (_foo_)
foofooo foo_foo
___foo___
xxx_foo_zzzz xxxfoozzz
0000 foo_
9999 _foo...
foo_abc cba_foo
a foo_ _foo bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);