#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)/acs/([^/]+/[^/]+)/"
Local $sString = "https://mywebsite.com/acs/region/USA/news/asdf.com" & @CRLF & _
"https://mywebsite.com/acs/region/ARG/news/asdf2.com" & @CRLF & _
"https://mywebsite.com/acs/dtcp/en-us/news/asdf3.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")