re = /\/acs\/([^\/]+\/[^\/]+)\//m
str = 'https://mywebsite.com/acs/region/USA/news/asdf.com
https://mywebsite.com/acs/region/ARG/news/asdf2.com
https://mywebsite.com/acs/dtcp/en-us/news/asdf3.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end