// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)/acs/([^/]+/[^/]+)/").unwrap();
let string = "https://mywebsite.com/acs/region/USA/news/asdf.com
https://mywebsite.com/acs/region/ARG/news/asdf2.com
https://mywebsite.com/acs/dtcp/en-us/news/asdf3.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}