import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/acs/([^/]+/[^/]+)/";
final String string = "https://mywebsite.com/acs/region/USA/news/asdf.com\n"
+ "https://mywebsite.com/acs/region/ARG/news/asdf2.com\n"
+ "https://mywebsite.com/acs/dtcp/en-us/news/asdf3.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}