package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)/acs/([^/]+/[^/]+)/`)
var str = `https://mywebsite.com/acs/region/USA/news/asdf.com
https://mywebsite.com/acs/region/ARG/news/asdf2.com
https://mywebsite.com/acs/dtcp/en-us/news/asdf3.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}