using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"['""](.*?)['""]";
string substitution = @"""REPLACED""";
string input = @"this is ""some sting"" whatever 'another string'";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}