using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"(([\d]+)([\s]+)([a-z]+)(\s([a-z]+))+([\s]+)([\d\.]+)([\s]+)([\d]+)([\s]+)([\d\,\.]+))";
        string input = @"                     ESTORNO - SINDIÇU
 ---------------------------------------------------------
| CN-SIAP                                           CONAM |
|                                                         |
|              Prefeitura Municipal de Mogi Guacu         |
|                                                         |
|                                                         |
| DATA 03/01/117  RELACAO DE DIFERENCA DE DESCONTO PAGINA |
|---------------------------------------------------------|
|                                                         |
|   SERVIDOR           ORGAO   LOCAL  VALOR DO DESCONTO   |
|---------------------------------------------------------|
| 123 MATHEUS HENRIQUE 15.01.00 000123      10,00         |
| 1123 JOAO VITOR 20.01.00 000153           100,00        |
|---------------------------------------------------------|";
        RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
        
        foreach (Match m in Regex.Matches(input, pattern, options))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}