re = /(([\d]+)([\s]+)([a-z]+)(\s([a-z]+))+([\s]+)([\d\.]+)([\s]+)([\d]+)([\s]+)([\d\,\.]+))/im
str = '                     ESTORNO - SINDIÇU
 ---------------------------------------------------------
| CN-SIAP                                           CONAM |
|                                                         |
|              Prefeitura Municipal de Mogi Guacu         |
|                                                         |
|                                                         |
| DATA 03/01/117  RELACAO DE DIFERENCA DE DESCONTO PAGINA |
|---------------------------------------------------------|
|                                                         |
|   SERVIDOR           ORGAO   LOCAL  VALOR DO DESCONTO   |
|---------------------------------------------------------|
| 123 MATHEUS HENRIQUE 15.01.00 000123      10,00         |
| 1123 JOAO VITOR 20.01.00 000153           100,00        |
|---------------------------------------------------------|'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end