import Foundation
let pattern = #"(([\d]+)([\s]+)([a-z]+)(\s([a-z]+))+([\s]+)([\d\.]+)([\s]+)([\d]+)([\s]+)([\d\,\.]+))"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
                     ESTORNO - SINDIÇU
 ---------------------------------------------------------
| CN-SIAP                                           CONAM |
|                                                         |
|              Prefeitura Municipal de Mogi Guacu         |
|                                                         |
|                                                         |
| DATA 03/01/117  RELACAO DE DIFERENCA DE DESCONTO PAGINA |
|---------------------------------------------------------|
|                                                         |
|   SERVIDOR           ORGAO   LOCAL  VALOR DO DESCONTO   |
|---------------------------------------------------------|
| 123 MATHEUS HENRIQUE 15.01.00 000123      10,00         |
| 1123 JOAO VITOR 20.01.00 000153           100,00        |
|---------------------------------------------------------|
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
    var groups: [String] = []
    for rangeIndex in 1 ..< match.numberOfRanges {
        let nsRange = match.range(at: rangeIndex)
        guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
        let string = (testString as NSString).substring(with: nsRange)
        groups.append(string)
    }
    if !groups.isEmpty {
        result.append(groups)
    }
}
print(result)