use strict;
my $str = '                     ESTORNO - SINDIÇU
 ---------------------------------------------------------
| CN-SIAP                                           CONAM |
|                                                         |
|              Prefeitura Municipal de Mogi Guacu         |
|                                                         |
|                                                         |
| DATA 03/01/117  RELACAO DE DIFERENCA DE DESCONTO PAGINA |
|---------------------------------------------------------|
|                                                         |
|   SERVIDOR           ORGAO   LOCAL  VALOR DO DESCONTO   |
|---------------------------------------------------------|
| 123 MATHEUS HENRIQUE 15.01.00 000123      10,00         |
| 1123 JOAO VITOR 20.01.00 000153           100,00        |
|---------------------------------------------------------|';
my $regex = qr/(([\d]+)([\s]+)([a-z]+)(\s([a-z]+))+([\s]+)([\d\.]+)([\s]+)([\d]+)([\s]+)([\d\,\.]+))/imp;
if ( $str =~ /$regex/g ) {
  print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
  # print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
  # print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}