// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r"(?im)(([\d]+)([\s]+)([a-z]+)(\s([a-z]+))+([\s]+)([\d\.]+)([\s]+)([\d]+)([\s]+)([\d\,\.]+))").unwrap();
  let string = "                     ESTORNO - SINDIÇU
 ---------------------------------------------------------
| CN-SIAP                                           CONAM |
|                                                         |
|              Prefeitura Municipal de Mogi Guacu         |
|                                                         |
|                                                         |
| DATA 03/01/117  RELACAO DE DIFERENCA DE DESCONTO PAGINA |
|---------------------------------------------------------|
|                                                         |
|   SERVIDOR           ORGAO   LOCAL  VALOR DO DESCONTO   |
|---------------------------------------------------------|
| 123 MATHEUS HENRIQUE 15.01.00 000123      10,00         |
| 1123 JOAO VITOR 20.01.00 000153           100,00        |
|---------------------------------------------------------|";
  
  // result will be an iterator over tuples containing the start and end indices for each match in the string
  let result = regex.captures_iter(string);
  
  for mat in result {
    println!("{:?}", mat);
  }
}