$re = '/<audio\s+src="([^"]*)"[^>]*>/i';
$str = '<p><audio src="test.mp3" controls="controls"></audio></p>
<p><audio src="test2.mp3" controls="controls"></audio></p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);